Cross Track Error

When following a route with the autopilot, if I deviate from the route to avoid debris in the water or another vessel for example, occasionally when I return to the route, I cannot reset the cross track error using the “x” on the keyboard. The only way I can reset the XTE is to deactivate the route and reactivate it.


Hi Tom,

I want make sure I understand what you want. Are you saying that you want your Autopilot to bring you back to the route, as if you hadn’t deviated from it, or that you want it to head straight to the next waypoint, as if there was a new route leg from your deviated position? Thanks.

To answer your question regardless of the above, the second you press X on the keyboard, you should immediately get a new active leg, straight to the currently active waypoint and starting at the location of your vessel. That is the indication that we recognized that you pressed the X key. The only thing that should prevent X from being recognized is if you have clicked inside something like a text field, which would take your X as its input, or any control that has its own use for X. Is it possible that you have clicked on a control of some sort (such as a text field) that has its own use for X? Did a green leg appear at your vessel symbol when you clicked X?


The simple answer is no. I wanted the autopilot to go direct to the active waypoint. When I instruct the Raymarine autopilot to go into “Track” mode where it will follow the active route in CE after I have done an avoidance maneuver, if I don’t cancel the XTE by hitting “X” on the keyboard, the autopilot will make a hard turn to get back to the track. To prevent that, I cancel cross track error so the new track is direct to the active waypoint. This generally works but sometimes I can’t cancel cross track error by hitting X as CE doesn’t respond. If I deactivate the route and activate it, I can then cancel cross track error by hitting X.



I think Steven is on the right track. When CE doesn’t respond, it’s usually because Windows has decided you want the focus to be somewhere other than the active chart window. That is usually related to whatever you clicked on most recently. To get the Windows focus back to CE, just click anywhere in the active chart window. Then click again to get rid of the annoying property box that CE assumes you wanted. After that, Windows will again feed your keyboard input to CE, and your X will work as you intended.

After a while, you get used to feeding CE a couple of clicks every time you do anything outside the chart window.

You can also put a Reset XTE button on the instrument panel. Or, when you put the Route Monitor instrument on your panel, you get a Reset XTE button under the cross track indicator. If I remember correctly.

I am going to see if it is a problem with the active window, but waiting for it to occur again. I don’t think it is an issue with the active window as I can right click on the route and deactivate it.

On a separate issue, the property block is a big annoyance and most of the time useless for you to clear it off the screen. For example right clicking on a route to activate it, brings up a property block that isn’t needed and then has to be cleared. The same with activating a waypoint inside a route. Maybe a better option is requiring a double mouse click to bring up the property block.


I frequently find that clicking on a route brings up 2 property boxes and they like to land on each other, another annoyance is if you want to extend a route and need the “lollypop” to come up, clicking on the route brings up a property box right over the “lollypop”, so you have to zoom out, or move the chart and try again.