Globalsat BU-353 S4 GPS

Having trouble getting R P N System to recognize my antenna. Laptop beeps when I plug it in and its little red led flashes. Any help welcom

Have you tried anything in Configuring Electronics (Windows Only) or in NMEA 0183 COM Port Troubleshooting (Windows Only)? If you have, what is or isn’t happening?

Still unable to get Rose Point to recognize antenna. Hired computer “repairman” to help. He gave up after 45 minutes. PL-2303 Driver installer did not recognize COM port during setup. Tried driver setup on another laptop and it did recognize the COM port. Problem could be in my computer. If I get another one , how do I transfer my Rose Point product onto it?

Hello Dominique. Just install Coastal Explorer the way you did on your other systems, then activate it using your Product ID. Here is the page on our site where you can download the full installer.

Note that the Product ID you sent is not quite correct and that’s actually a good thing, since we do not recommend posting your Product ID to a public forum like this one.

Also note that you may want/need to copy your voyage plan document (.nob file) from your old computer to the new one, so you have access to any routes, etc., that you’ve created.

If you have any problems with installation or activation, it may be simplest to help you via a phone call. 425-605-0985

I am having a very similar issue.

All last season RPN worked fine and recognized the usb gps antenna
This season upon first use the software is not recognizing the same antenna and no changes have been made to the computer. I watched the tutorial videos.

Also a Dell laptop

I suggest giving our support department a call, so we can more easily go over possible solutions.


I appreciate you following up.

I have resolved this issue through some sleussing of my own. The com port “disappeared” so i removed the device/driver from the sensor tab and restarted. Everything is fine now

1 Like