How do you delete Shared Layers?

How do you delete Shared Layers from a laptop?

If by “Shared Layer” you are referring to a cloud-synchronized layer, you can delete one by following these steps:

  1. Open the “Layers > Layers” page
  2. Select the layer
  3. Click the Edit button in the Current Layer box at the top of the page
  4. Click the Delete Layer button at the bottom of that page


The red Delete Layer button works only on layers not shared, there may be a bug. I went to the website and logged in, no problem. I created a few layers and shared some of them, I am unable to delete the shared layers, or unshare them. The shared layers do not include any routes, maybe that’s part of the problem.

When I open Coastal Explorer and select Layers, the shared layers do not appear in the list of layers. Maybe that’s because they do not include any routes.

I really like this feature and will be using it; but, I presently do not understand how to resolve my problem.

Thanks, Royce

I’m confused about what you mean by “shared layers”. Can you explain what you did to share some layers with the website? Coastal Explorer only has two types of layers: Voyage Plan Documents and Cloud-Synchronized Layers. Perhaps you are referring to “Cloud-Synchronized” layers as they are “shared” between the Coastal Explorers using your account?

If that’s the case, then Voyage Plan Documents can only be deleted by moving or deleting the file using the Windows Explorer and Cloud-Synchronized Layers can be deleted by using “Layers > Current Layer > Edit > Delete”. (I failed to mention originally that you need to click on the Current Layer box to see the Edit button on the website, we’ll be changing that soon.)

If you see a red Delete Layer button for a layer, then it is a Cloud-Synchronized Layer and the button should work; if it’s not then that would be a bug. This does work for us, but we’ll do some more testing trying to find a problem.

Coastal Explorer should display the Cloud-Synchronized Layers, but it can take a while if you’ve imported large Voyage Plan Documents. Be sure to wait until a synchronization finishes before checking for layers that Coastal Explorer hasn’t displayed before (you can tell the synchronization has completed when the circular arrows on the Settings button stop spinning).

While trying to reproduce this problem, we did find something but I’m not sure if it’s the same as what you are seeing. Here’s what we did:

  1. Used the website to create a new layer with “Layers > Layers > New Layer”
  2. Verified that the layer appeared in Coastal Explorer for Windows on a different PC
  3. Used Coastal Explorer for Windows to delete the layer
  4. Verified that the layer was removed from the list on Coastal Explorer for Windows
  5. Checked the website on the other PC
  6. Found that the layer was still listed (a bug)
  7. Refreshed the web page and found that the layer had been removed

So in this case, the delete is working, but the website is not correctly removing the deleted layer from the list. Is that what is happening to you?


My primary laptop is a new Dell XPS running Windows 11 and the Edge browser. My secondary (backup) laptop is a Dell Inspiron running Windows 10 and the Edge browser. When both are logged in to the website they get the same view (1st pic); however, it’s not the view shown in CE (2nd pic). I know the files in the CE view would not appear in the website view.

A change in CE on the XPS quickly reflects on the Inspiron. It’s the website view that does not update, even after several minutes. Also; the untitled layers will not delete, and the test1 to test2 (read only) layer cannot be selected (highlighted) or deleted.

I can’t reproduce it now, but I did share several layers. These are the layers I cannot delete. The share menu item seems to be gone.

Hope this helps,

found the shared layers menu item

Thanks for the new information. That Shared Layers item should not be there, but I now see it will appear at times so will get that fixed right away.

You’ve found a feature that we are working on, but that is not ready to be used and is supposed to be hidden. The main reason it is not ready is that is can cause the sort of synchronization problems that you are having. I had assumed it was inaccessible and that is why I was confused by your use of the term “shared” and why I didn’t suspect this was the cause.

I can “unshare” these layers by adjusting the database on our servers and that should fix your list. Do you have items in those layers that you want moved back to their “unshared” status, or can they just be deleted? (I can save any items that are currently shared, but it might take longer…)

I saw that all of the shared layers were empty, so I went ahead and deleted them from the shared layer database. They should not appear in your list anymore.

Thanks Brad, I appreciate the help. This feature will make it a lot easier to keep my routes organized and my backup in sync. …Royce