iPad subscription not working

I use coastal explorer on my iPad every day. Today it won’t connect to my NMEA data. It says I need an active subscription which I have and renews in May.

I have tried to go into the charts and adding store but when I click on it all I get is a blank panel.

The Charts and Add-Ons Store was broken by a recent update (1.2.0), but Apple approved another update to fix that early this morning (1.2.1). If your iPad has not already updated Coastal Explorer, you can force an update using the App Store. That should make Coastal Explorer aware of your subscription without doing anything else, but if it doesn’t, tap the “Restore Purchases” option at the bottom of the Charts and Add-Ons Store page.

How do I force an update?

I can’t get to the restore purchases button my tab goes blank after I get to the charts and add in page

You force an update by going to the Coastal Explorer page in the App Store; the button that normally lets you purchase or install an app will say “Update” when an update is available for an app that is already installed.

Thanks. The update option wasn’t available this morning but it worked now and it working as it should. Thanks again.

Updates are normally automatic, so it must’ve happened since your previous message. I’m glad everything is working for now and am sorry for the inconvenience!

I’m having this same issue as well. There was no available update for the app. The deleted and reinstalled it but its still not working. Just says subscription approved

Do I understand correctly that an Internet connection is required to start the CE app? Is an Internet connection required while the CE app in running?

Are you Android or iOS?

No, an Internet connection is not required to start Coastal Explorer or use it.

You have a subscription, which allows you to both download charts onto your device as well as connect to marine electronics equipment, including a built-in GPS if your device has a GPS.

I am using an running IOS

Any follow ups on this issue

What version of Coastal Explorer do you currently have on your iOS device?

I have version 1.2.2 installed

Hi kcobb41,

Is this the same iOS device you bought the subscription from, or have you also installed on a different iOS device? If so, there should be a “restore purchases” choice in CE on that device, so it becomes aware that you’ve purchased the subscription.

I purchased the subscription on my iPad. I’ve hit that restore purchase button countless times with now results. I’ve reinstalled the app as well with results. It’s just saying approved letting know I have the subscription. But all the features are saying subscription required. Call someone call to get this worked out?

I cannot call you since I don’t know your phone number, but before I ask you to call me, we have one more thing to try, a thing you’ve already tried several times, but we’re asking for one more. Please try restore purchases again. If that works, let us know here. If it doesn’t, call me.