March 18 build, no instruments

Hmm, loaded the latest build. Instruments have disappeared, tapping the inst gear prompts one to sign in, but the sign in doesn’t work. Also I have not had a Nemo feed in over a week.

That’s odd… Do you have an internet connection? That might be needed to get things started. Also, you might try signing out and back in (in Settings > Accounts).

1 Like

Signing out and back in fixed it for me👍

Yes, have connection. Signed in, blank screen as above, signed out it sorta works, but the instrument settings button goes away. Also only heading is coming from Nemo, position, n2k data not there

The instrument settings (gear) button will only appear if you are signed in, so that’s normal. I’m not sure what else to have you try to get instruments when you are signed in, though, as this hasn’t happened in our testing. (It sounds like it happened to BUBBA, but signing out/in fixed it. Other than that, I don’t know of this happening to anyone else.)

I do have two questions that might lead to clues… Have you imported or created a lot of navigation objects? Do you have another device with the Coastal Explorer beta?

As for your Nemo Gateway problem: it looks like Coastal Explorer is receiving depth, speed, and position at some point, but then the data stops. Is it possible that your iPad is losing the connection to the gateway? What do you see on the Settings > Electronics page? (BTW. while I as trying to test the gateway interface, I noticed that the ability to see individual port pages is broken in the current build. However, the main Nemo Gateway page works and the problem shouldn’t affect the ability use the data.)

this is what I get if I sign out and go-to electronics page. Nemo is also feeding CE on the PC which is on the router through a switch. That is working fine. Weird that the Nemo shows online, and I’m getting heading, but the feeds that provide the data are not showing online

I think there is a problem with the Online indicator and your gateway connection has really been lost. The heading is probably coming from the iPad itself (which is a new feature in Coastal Explorer). What happens if you exit Coastal Explorer and restart it? If my theory is correct, I would expect that it would not show your gateway since it won’t be able to find it on the network. But if I’m wrong, it might find it and things might work for a bit (which would be a good clue).

Tapped the heading and it’s showing internal sensor. It does occasionally grab a position, where from IDK.
Restart does nothing, still showing Nemo online but nothing else.
If you want we can talk, u have my number in the file there?

Also please put an option to turn off completely the internal heading. Zero compatibility with a steel boat.

We just released build 46 which fixes a few Nemo Gateway related problems, including detecting when the connection to the gateway is lost and reconnecting when possible. Hopefully this either solves the problems you’re having, or lets us better troubleshoot them.

Build 46 also includes options for enabling and disabling using positions and headings from the Location Services.

If I am signed in, no Nemo. If I sign out, Nemo comes and goes.

depth and speed are n2k data, POSN and HDG are from 0183 porta

Well, you have me stumped… The Nemo Gateway really shouldn’t be affected by whether or you are signed in, unless you are also changing networks or something else when you switch.

Just so you know how things are supposed to work now (as of today’s build #46), the Online indicator for the gateway turns green as soon as the gateway is discovered, but it can take a up to a minute to change to red/offline if the connection is broken (it can be faster, but usually will be a full minute). The Receive indicators should turn green as soon as a sentence or PG is received and will turn gray if nothing is received for two seconds. Finally, the sensor status panels will turn green when the corresponding data is available and will turn red if no data is available for ten seconds.

I’d love to get to the bottom of this problem, but am running out of ideas based on the information I have so far. The gateway interface is working quite well in the testing I’ve been able to do, so there must be something different in what you are doing, how your network(s) are setup, or in how your gateway is being used. If you could provide more information, we might have a better chance at solving this… In particular, can you confirm/answer these things:

  • You have installed build 46
  • You are not changing your Wi-Fi connection after the Nemo Gateway is discovered
  • Is the Nemo Gateway not even discovered if you are signed in or do you just not receive data from it? (It will only show up on the Electronics page if it has been discovered on the network since Coastal Explorer was started.)
  • Does it seem like there is a specific amount of time between when the gateway is discovered and when it stops working?
  • Do your Receive indicators ever show green? (they have always been gray in the photos)
  • Have you looked at the individual port page to see if data is getting garbled?
  • Did you turn off the new “Enable Device Heading” option in “Settings > Electronics > Location Services”?
  • Can you think of anything else that might be a clue?

yes, build 46, wifi is stable on the network that Nemo is on. I set the iPad to ignore all other networks while using it for nav. Nemo shows on the electronics page.
If I am signed in, it doesn’t work at all. Literally I get a blank chart, no instruments, Nemo is missing, the status indicators are gone too, the entire instrument panel is blank black. If I tap on the instrument settings, I get a pop out on the left panel that ask to sign in. Notice that this is while I am actually signed in. If I sign out, it comes back to life.
Signed out, it works, but cannot edit instruments. Nemo comes and go’s.
I have a verizon mifi router novatel 5500 that connects to the internet and is the main router for the network. There is an industrial network switch between the router and Nemo. The PC is on the same ethernet switch. The PC is very stable and never drops data out.
The iPad is on the wifi output of the mifi 5500 router. I do use another PC laptop via wifi and CE has no problems on that.
I have noticed that if I navigate to the IP address the nemo is at via the main nav PC that the feed to that is very slow and switching between pages doesn’t always work. The nemo page shows that firmware is up to date. I think the problem is in the Nemo.
I have never seen the ports as shown on the electronics page (iPad) go green, only the Nemo online shows green.

I have TZ installed on the iPad and it works with full sensor data and AIS so I know the feed from Nemo is getting to the iPad. I have tried using iPad with both CE and TZ running and with just CE running (restart ipad between switches so I know TZ is off).
Do you have a way to tap into my network via remote and poke around for a looksee?
We have been offshore working for NOAA the last week, so I can only look at this occasionally. Off today, but back out tomorrow.

I received the adapter to plug rj45 into iPad, everything works this way.