MOB & Event buttons

The Mob & Event buttons do not presently work on my iPhone. I assume this hasn’t been addressed yet. I really like CE on both my iPad and iPhone. The Event button will be useful next year during crab season. I have installed an iPhone holder and a USB outlet in my skiff.

Pat Harman

Both of those buttons should work as long as you’ve signed in (though the MOB mark does not yet get activated as a waypoint).

I am logged in. Event does not create a way point. Also vessel position is intermittent, My goal is to create a waypoint to return to a crab trap next year. Because it works at your end I assume I have a setting problem at my end.


It could be caused by your intermittent position, and that could be caused by a bug we just found and fixed if you are using the iPhone’s Location Service. I expect an update to be released very soon that will fix that.

However, are you able to create other types of objects (such as a regular mark)?

I can’t make any type of mark. However, I can see the menu of annotations


I got to my boat today. I tested my iPad and got the same results as on my iPhone. I can’t make a mark, MOB, or insert an annotation.

I have a minor request for version 2 or 3. Could we have a symbol of a crab in the annotation table.


It sounds like you’ve run into a problem with object synchronization that we’re trying to track down…

We are preparing an update that might make this work better, and definitely provides more information about when object synchronization is going on. This update should be available today or tomorrow.

In the mean time, you might try signing out and back in. Sometimes that gets things going again.

I got the event to work. I had to delete CE reboot the iPhone and install CE again. The buttons for zooming in and zooming out have disappeared.

I like the new screen in portrait mode…


Now the event and and annotation no longer work on my iPhone or my iPad. I have deleted and reinstalled the app and rebooted… Very strange.


The zoom in and zoom out buttons now work in landscape mode. Not enough room in portrait mode.

The instrument panel no longer functions below is a screen shot I hope it helps.

The instrument panels rely on the same synchronization mechanism as the navigation objects. Have you tried just signing out and signing back in?

The zoom buttons are removed when the screen isn’t wide enough for all the buttons (such as an iPhone in portrait orientation, or a skinny panel on an iPad with a split screen). This is done so that the other buttons can still be reached since you can also zoom in and out by pinching the chart.

Yes I have signed out, then signed in. I have deleted the ap and reloaded it. I assume it works at your end. Same result on both my iPad and iPhone. I would be willing to bring my devices yin so you can look at them.


Yup, it’s working here…for now, at least. We have seen this happen on some of our devices but thought it was fixed in build 54. Thanks for the offer to bring your devices in, but I’m afraid that wouldn’t really help since we’d need to set them up as ‘developer devices’ which would probably change enough that the problem would go away! We’ll keep working on it, though, and maybe add some logging that could be submitted from devices that are having the problem.

I have encountered this issue as well. No buttons work, the instrument panel is not available, and no collections can be created. I fixed this issue by forcing a sync after logging in. Once the existing collections and databases were able to be downloaded, the app worked as it should.

I believe that this is tied to the way the app behaves when collections are not available, and to be frank, the way it behaves right now is a bit tricky. Let’s say that I dropped my iPad and broke the screen, and now I needed to get CE installed on another device but I have really shotty internet. Downloading the App might be possible, but downloading the entire profile with the collections and tracks would be difficult. In the current configuration and the way the app behaves, I would not have a useful piece of equipment that I would hope to have available for sailing. I can see this being a bigger issue as many people start migrating to the new Mac computers with Apple sourced processors as main nav PCs, because of the compatibility between the iPad and Mac platforms.

With build 55 neither the MOB or the Event buttons work on my iPad or my iPhone. Sorry I can’t give you any clues.

Patrick Harman