Pointers and numbers disappear in wind instruments, iPad, iPhone

I have an iPad 10,2 iOS 14.4 and an iPhone SE iOS 14.4 and use Yacht Devices YDWG-02 for the connection to the instruments. IPad CE is dated 28th January. I am in Europe and could at that time download the release from app store.
Everything works fine except for the wind instruments. The pointer and the numbers can be seen for a few seconds and then disappears for about 10-30 seconds.
I have tried both UDP and TCP with the same result.

I have also used the same configuration (but both Transmit and Receive) to connect Windows CE without any problems with the wind instruments. Any ideas?
In this configuration also autopilot control seems to work fine with the YDWG-02.

Hello Jan,

If the wind is going away, there must be some interruption in the sentence that’s coming from the WiFi Gateway. It’s possible that the sentence is still being delivered, but that the important data within the sentence is being left out. Either way, it should be possible to see a change in the data being received when you troubleshoot that port.

If you select that port in Settings > Electronics, you should see all the sentences being received in real-time, so look at what’s being received when it is working with wind and when it isn’t. Let us know what you find.

By the way, UDP is generally the best choice when available, so I’d stick with that as it’s generally more reliable.

Hallo Steven,
Thank you for the quick answer. I will do what you suggest, but can you explain why it’s working with Windows CE and the same configuration. What is different? Thanks/Jan

We don’t know why, unfortunately.

I think our best chance of figuring out why is to have you send us an Electronics.log file from your PC Windows, during the time when the problem is happening on your iPad. We can take the data from your PC and feed it into the iPad app to see if there’s a clue there.

To do this, click the Search button at the left of your PC Coastal Explorer, and type $data into the search box at the top. This will open a Windows File Explorer to our data folder. In there, you’ll find the two files we’re interested in. The most important will be the file named Electronics. Note that the capital E is important, since there is another file named “electronics” with a lower-case. Since you’ll be in there, you might as well get the one called “PreviousElectronics” as well. Just send both of those files to support@rosepoint.com.

Another thing that could be useful is a screenshot of the port’s status panel, where you can see the incoming data. Please do this when the wind data is failing to work correctly then send that along with the Electronics and PreviousElectronics files.

We think we understand what’s happening here.

The MDA sentence is being treated with a higher priority than the MWV which should not be the case. Since the MDA sentence is providing N/A for the wind info and has a higher priority, it is clearing the wind info from the MWV sentence.

We will change the priorities and that should solve this.

Many thanks Steven! I live in Europe. Do you inform about the update in the community and is there any possibility that I can download the update?

Coastal Explorer for the iPad/iPhone is updated identically to any other Apps you may have obtained through Apple’s App Store. However, you are in Europe and we don’t yet have the app available in the App Store in Europe. We are working on solving this before the next update.

After the update. I have tested and the wind instruments work excellent! Thanks!

1 Like

Excellent news! Thank you.