The Beta Test is Over

We are excited to announce that the Coastal Explorer on the iPad and iPhone Beta Program is over and Coastal Explorer is now available in the App Store!

Thank you for participating in the Coastal Explorer beta test! The bugs you’ve reported and the feedback you’ve provided have helped make Coastal Explorer a better app. We hope you enjoy using it as much as we do!

Over the next few weeks we will be shutting down the beta test on TestFlight and converting this forum from a beta test HQ to the primary support site for Coastal Explorer on all platforms.

While the Coastal Explorer beta test is over, we still have a lot of exciting new features planned. To continue to get updates, be sure to install Coastal Explorer from the App Store at ‎Coastal Explorer on the App Store.

1 Like

Hey Brad, I’ve downloaded and am updating from app store. In the app store, it just says, “in app purchases” I’m not seeing anything in settings. Where do I go to actually buy it?



Excellent! I think you’re the first. I hope it goes well! :wink:

For the next month or so, it’s all free for Coastal Explorer 4 owners. After that (and now for new users), chart subscriptions can be purchased in Settings > Charts and Add-Ons. There’s a bit more information on how this will work our website.

1 Like

I can’t find Coastal Explorer in the Apps on my iPhone. Nevermind. It is Not under Coastal Explorer. It is under Rosepoint.

Are Canadian charts available? (Raster or Vector?) I went into Settings>Charts and Add-Ons, expanded the coverage area to include Vancouver Harbour. Only general charts display. But no detail (depths, etc.)

I have a current subscription to BC Raster & Vector charts for my PC version of CE.

iPhone 12 (iOS 14.4)

Only US Coastal Charts are available right now, but we hope to add US Inland and Canadian options soon, and more later.

I downloaded the app and updated but it says I have 17 errors. How do I get clean update?

You can delete the app and then install it from the App Store to get a “clean” update. I’m curious where you are seeing these errors and what they are, though. Can you post a screen shot?

Thanks! Unfortunately I can’t think of any reason you’d get that particular error… It’s possible that it’s caused by some changes we made to how data is stored on our servers for the cloud-syncing feature. Do you have any navigation objects that you created during the beta that you would prefer not to lose?

No. I didn’t delete the beta app before installing the new version. I deleted everything and installed new app. Everything appears ok. Thanks,

I’m glad it’s working now! Thanks for the info and screenshot; hopefully we can figure out to keep this from happening to anyone else, but it’s good to know that a clean install will do the trick.

Brad, my iPad had clean install. On my iPhone I received note there were 5 errors. I hit update again. Then I had 3 errors. Hit install again and it completed.

On your iPad, did you see anything like the “You are not a server admin” message after “YOUR DATA UPDATED”?

That error on your iPhone had to do with moving your data (navigation objects and instrument panels) from the form we used in the beta to the new form. I believe that problem has been solved, but if you saw another error message there, then maybe not…

The red number of errors has to do with updating charts for offline use. The Update Now button doesn’t actually have anything to do with your own data as that is updated continuously, it only starts a download of the charts, places, and predictions for offline use. Only the data you don’t have already is downloaded, so each time you pressed the button, Coastal Explorer tried to download what was missing and eventually got it all.

I’m not sure why you got any errors, but we have restarted our systems a couple of times today as new users are finding new problems, and that could have been the cause. Or, if you still have some NOAA RNC charts selected for download, their servers are usually overloaded and frequently have some errors.

I previously installed the beta and now have installed the released version from the app store after completely deleting the beta. Most functions seem to work and I can connect my NMEA feed. However, if I go to screens, I get the following error:

There was a problem accessing your instrument panels.

Waiting for collection ‘instruments-847’ to exist

Any ideas?


We had a problem on our server that could have caused this. Could you try again? (You might need to sign out and back in using Settings > Accounts if it doesn’t work right away.)

Just downloaded and spreading the word to co worker’s and friends. Thanks for letting me participate in the testing :+1:

1 Like

Thank you for participating BUBBA, and for spreading the word!