Wandering with CE and Simrad AP26

I recently connected Coastal Explorer to my Simrad AP26. I can see the data being transmitted and the AP is accepting and is actually following the route but our path is very loose. The boat wanders back and forth up to 100-125ft to either side of the route line. I’m wondering if this is a speed problem where the AP isn’t getting appropriate STW data or some other setting that needs to be changed to tighten up the route guidance.


The only thing we can provide your autopilot that might have an impact on this is Cross-Track Error (XTE). The default precision in Coastal Explorer’s talker options is three digits, which is just over 6 ft. If your XTE precision is set to fewer digits, try setting it to a higher precision. Some autopilots will not handle too many digits, so be sure to set it to the highest precision your autopilot works with.

Here’s a screenshot of my talker options, showing you how the default precisions are set. I have highlighted XTE with a red rectangle surrounding it. If yours is set like mine, then you may want to contact Simrad on how to get your AP to stay on the intended track more accurately; there may be calibration options that will help, although you’ll want to check the other precision values as well, especially bearing, since that might also help.

Thanks. My settings are the same as yours (default), so I’ll reach out to Simrad as well.

This sounds to me like a Simrad autopilot issue. The “Rudder/Counter Rudder” settings are off. Try following the Simrad manual for redoing the Sea trial which will reset rudder and counter rudder. Also, you can go into the autopilot menu at the control head and change only these two settings but this can have you chasing your tail as you guess what might work. I find redoing the Sea Trial produces the best straight line route following as the autopilot automatically figures out what works best for your vessel.