Coastal Explorer Beta Feature Overview

Thanks for participating in this Coastal Explorer on iPad and iPhone beta test! With your help, we hope to finish this version of Coastal Explorer before this year’s cruising season begins. Here’s an overview of what is working now:

  • Various map and chart options
  • US Raster Charts (NOAA RNC) may be installed for offline use
  • Create marks, routes, range/bearing lines, boundaries, and more
  • Import Voyage Plan Documents (‘NOB’ files) and GPX Files
  • Navigation objects are synchronized across your devices
  • View your Coastal Explorer Network Blogs
  • Active Captain viewing
  • Text weather forecasts and NEXRAD images
  • US tide level predictions (current predictions will be added soon)
  • National Data Buoy Center observations
  • Search the gazetteer, Active Captain, AIS vessels, and more
  • Unit conversions in the search browser
  • Various instrument panel displays (customization is coming later)
  • Interface with your Nemo Gateway to access your boat’s GPS, heading sensor, depth sounder, AIS, etc.

What about “Tracking”. tapping on the vessel icon I see “Start Tracking”, but it doesn’t seem to do anything. Is that for future, or am I ding something wrong?

Tracking works, but there is a problem where the Start Tracking command will appear but not do anything if you have not signed in. Could that be the problem? (Quite a bit of the program will not be accessible if you haven’t signed in. Most of the things that are disabled will show a message about that and provide a way to sign in, but the Start Tracking option doesn’t yet…)

When I tap on the Coastal Explorer app on my iphone it starts right up and shows my gps position on the chart, etc. I don’t see anything about signing in. Separately if I open TestFlight, that requires a sign in (sometimes). How should I be doing it?

I really like the similarity of appearance and function to the PC application.

One way is to click on “Settings > Account”… But also using the +New button on the chart, the Voyage Plan, or the Ship’s Log will ask you to sign in and provide a link to do so. (Once you sign in, you will stay signed in unless you use the Sign Out option or uninstall the app.)

Accounts shows me signed in. But, now I’m not even getting the “Start Tracking” pop-up.

Brad - what do I try next?

I assume by “Start Tracking popup” you mean the tip that appears when you tap the own-ship symbol on the map? We fixed a problem recently where that tip would not appear if the app was not getting a valid position. Are you running Build 50? If not, try again after updating.

Sorry - what is “Build 50”. I do get a gps position. It always looks right on.

Build 50 is the latest version of Costal Explorer on the iPad/iPhone. You can use TestFlight to find out which version you have and to install updates. TestFlight will normally notify you when an update is available, but only if you haven’t disabled its notifications.

I have been updating regularly. Today was the latest. I think it is “Build 51”. TestFlight showed “(51)”. Still no tracking.

Build 51 was released yesterday afternoon, so you are up-to-date. I’m afraid that at this point I really have no idea why this isn’t working for you. It works on every device we’ve tried and no one else reporting the problem. Could you provide more details on what type of device you’re using (iPhone or iPad), which version is iOS/iPadOS it has, and exactly what you are doing and what you are seeing. Perhaps that will provide the clue we need to figure this out. And just for reference, here’s how it should work:

  1. Coastal Explorer is started and once a position is obtained, the green own-ship symbol appears.
  2. Tapping on the own-ship symbol displays a ‘tip’ that says “Own-Ship” and a “Start Tracking” command.
  3. Tapping the “Start Tracking” command creates a new track (which can be seen in “Ship’s Log > Tracks”)
  4. While tracking is enabled, tapping on the own-ship symbol displays a tip that provides a “Stop Tracking” command rather than “Start Tracking”.
  5. Tapping the “Stop Tracking” command finishes the track being recorded and stops recording position changes.


Now with /build 51, tracking is working fine. Don’t know what the problem was, but it is fine now.

I had been following the procedure you describe.

I am using iPhone 8 with IOS 13.4.1

Regards, Frank