Uploading Navigation files

Having trouble accessing uploaded files to the IPhone

We did find a problem where a .nob file might not import when there are tracks present in the file. An update should be available in the next day or two that solves this problem.

I don’t know if this is the cause of your problem. If, after trying it in the forthcoming update, you still cannot import, please provide a detailed description of all the steps you took when importing, such as what technique you used to get the .NOB file onto your iPhone/iPad, so we can delve deeper into your specific use case.

Thank you, and welcome to the forum.

I have also tried to export route information from my PC Versuib and to import into the iOS Beta Version 33. The steps I took were to go to Voyage / Files / Export then selected all objects and saved twice - once’s as an NOB file and once’s as a GPX file. I then mail to an acccount that I retrieve on my iPad and save in Files under my Documents directory. On the iPad I then make sure I’m logged in and then go to Voyage and Files and Import. I navigate to the right directory and see both files, but the NOB file is grayed out and nothing happens when I click on it. I then try clicking on the GPX file which IS not grayed out and nothing happens. I’m happy to send you the files for testing if you’d like. Thanks very much, Dan

1 Like

I have exported the CE .nob file as well as an individual route as a .nob file (no tracks or marks included) and as mentioned before, the file is grayed out when I try to import into the iPad app. Nothing happens. I then exported an individual CE route file as .gpx and attempted to import it. The .gpx file is not grayed out but still nothing happens when I try to import it.

We are not sure what is causing these issues for some users and have not been able to reproduce either the “gray icon” problem or the “doesn’t do anything” problem ourselves, but are are working on it…

While we figure this out, it might help to try a different method to get files to your iPad or iPhone. If you have setup iCloud for Windows on your PC, then you can simply copy a Voyage Plan Document (“NOB File”) to your iCloud Drive folder and have it appear on your iPad where you can import it. You can also use OneDrive, DropBox, or a similar service to do the same thing, but you will need to link your OneDrive, DropBox, or other account to the Files app on your iPad/iPhone.

We will be releasing an update for Coastal Explorer on the PC soon that will work with new cloud-based collection format used by Coastal Explorer on the iPad and iPhone. This will remove the need to import files this way as everything you do on any device will automatically appear on your other devices.


One possible reason I am unable to import a .nob file may be that I run CE on a Mac with Parallels and exported the file from there. I can’t think of anything else that is different or why you can’t duplicate the issue.

We use a lot of Macs here with both Parallels and VirtualBox and they are working fine, so I don’t think that is causing any problems.

I believe the “gray file” problem is caused by the type part of the file name not being correct. If the file name does not end with “.nob” or “.gpx” then it will appear in the file selector, but in gray and it won’t be selectable. What’s not clear is why the name would get changed between the time it is exported and the time that it is imported, though I suspect it is happening when the file is attached to an email.

The problem of nothing happening when a file is imported has got to be a problem with our ability to import something in that file and whatever it is isn’t in our tests. @DanR: You mentioned you would be willing to share your problematic file with us… That would be great! Could you email it to beta@rosepoint.com? (Actually, if you send both the NOB and the GPX files, maybe we can see what is happening to the NOB file to make it show in gray as well as what it is about the GPX file that prevents it from importing…) Thanks!

Is it possible to move .nob files via USB using Apple lightning to USB adapter? I have not seen it mentioned in this thread. Thanks👍

After uploading gpx waypoints (marks) there are NO symbols rendered.

Coastal Explorer can open any NOB files that are available via Apple’s Files app which now supports USB storage devices as well as some network storage options. There isn’t a way to just send a file through USB though.

1 Like

Waypoints in GPX files can have a symbol names attached to them, but the actual symbol is not included in the file and there isn’t a standard set of symbols, so different programs use different names and most programs can’t show the symbols of other programs.

If your GPX file was generated by Coastal Explorer, then it would use Rose Point’s symbol names and the correct symbols would show up on marks. However, Coastal Explorer on the iPad and iPhone does not currently support icons on waypoints in routes, so that could be what’s happening here too…

Also, if you are using Coastal Explorer to export a GPX file which you are then importing into Coastal Explorer, be aware that GPX is a “lowest-common-denominator” format and you might be losing information. Only the NOB format can handle all of the various navigation object types and properties that are available in Coastal Explorer.

Thanks for the fast response and I also appreciate being part of the process, very cool.:+1::+1::+1: I was able to get my routes through the cloud which was hit and miss on my end do to not using the cloud before. One question when this release comes out will it work on Mac books as well or will you still need to petition Windows on those devices? Thanks

If on my iPad I bring up waypoint (mark) properties and change then ce both remembers and saves new icon SO just gonna say you DO support icons just not well. There should be a default during conversion that is something other than none. Personally I would like to configure default in setting but would settle for something very generic like a box :wink:

emails work well with other chart/map apps e.g. Gaia gps. User is allowed to send email attachment to apps supporting extension.

Even though waypoints and marks are frequently considered to be the same thing, in Coastal Explorer we specifically refer to the points in routes as ‘waypoints’ and points outside of routes as ‘marks’. On the iPad and iPhone, Coastal Explorer does support icons on marks, but not (yet) on waypoints.

We will change Coastal Explorer to make sure marks (not in a route) imported from a GPX file get a symbol in a future update.

1 Like

This new program is for iPad and iPhone only. Apple has a new way to make iPad apps work on macOS which we might be able to use later to make this run on MacBooks, but we probably won’t have time to look into that until after the iPad/iPhone version is done.

1 Like

I’ve moved some .nob files from my PC to Google Drive.

On my iPad I go to Voyage Plan - Files - Import Voyage Plan Document or GPX file and Browse to
Google Drive. I select the .nob file and it just goes back to the Voyage Plan page on the iPad and does not import the file. No messages.

Would you be willing to email your file to beta@rosepoint.com? We should be able to figure out what’s going wrong if we have the file.

I decided to restart with .nob rather than .gpx files. I deleted collections on phone. Collections on iPad were not deleted (not synced). I then attempted to import .nob file from files and Google drive. The file icon was greyed out. I then went to iPad and icons were not greyed out and so imported to iPad.

After import of .nob direction arrows which were off for all routes were turned on for all routes