Coastal Explorer on iPad Flashes and Loops Endlessly

I am a long time Coastal Explorer user on the PC. It has always worked well for me. I used it on a year long trip to Alaska and Mexico and it worked flawlessly. I am preparing for another trip to Alaska and Mexico and decided to add Coastal Explorer for the iPad along side my existing PC version of Coastal Explorer.

This weekend I bought Coastal Explorer for the iPad and paid for a yearly subscription. I am struggling with it. It is running on a brand new iPad Pro 12.9" with 516 GB of memory running iPadOS version 15.0.1 (The latest iPadOS as of 10/3/2021).

I struggled a little when downloading charts to the iPad but finally got that to work. For some reason when I tried to resize the charts, Coastal Explorer kept automatically re-centering the chart display on the Rose Point office in Kirkland.

Now when I try to open Coastal Explorer the chart display just flashes continuously and the program is completely unresponsive. The updating arrows appear next to the Setting button on the far right bottom as if it trying to do an update. None of the app buttons are responsive. I fact it “bricks” the entire iPad. The only way I have found to get out of this endless flashing is to power off the iPad.

After I updated my iPad to iOS 15 I have had the same nonstop flashing and looping as well. Thought it was just me. I tried restarting the iPad but this did not resolve the issue.
Update: I tried deleting CE iPad and downloading a fresh copy. After signing into my account I was not able to get the app to center on my current position and stay there. It continued to jump back to the Seattle area, (Lake Washington area).

Yes, It seems to be centering on the Rose Point office in Kirkland.

@PhilipGarrett: I’m sorry you had a bad experience with Coastal Explorer on your iPad! This is the first we’ve heard of anything like any of these problems and could use some more information to help get to a solution.

Coastal Explorer will center on location near our offices when it is first started and your position is not known. Once your position is found, it should center the chart there. When you change things about the chart, such as the type of chart to display, the follow mode, and the orientation, the location at the center of the view is saved along with those settings so that all of them are restored the next time you start the app.

We don’t know of any situations where it will automatically jump back to showing our offices, so would appreciate any help in figuring out what is triggering that for you. By “resize the charts”, do you mean zoom in and out? Or is something else triggering the re-centering?

Also, the default location is actually the north end of Lake Sammamish which is just south of our office in Redmond and southeast of Kirkland. After the jump, is the center of the chart actually in Kirkland or is it back to that default location in Lake Sammamish?

Can you describe the “flashing and looping” problem a bit more? Is it that the entire chart is flashing? If so, what is displayed when it’s not chart (a color, some other image, etc)? Do you recall what type of chart you had selected when this happened?

@rcassano : Did you also experience any lack of responsiveness when your screen was flashing? Do you recall what type of chart was selected? Did it also “brick” your iPad?

Hello Brad, I was not able to resolve the flashing and looping that both PhillipGarrett and I experienced so in my case I deleted the app and re-downloaded it. After signing back in the flashing / Looping thing was gone, but when trying to pinch the chart to zoom in or zoom out the chart would jump to the Seattle area - yes I see now it’s Lake Sammamish. If I touch the icon to recenter the boat at my current location - that works. I’m inland from the Chesapeake so need to scroll to the east to see the Bay. As soon as I try to move the chart it snaps back to Lake Sammamish. None of this was apparent before I updated to iOS 15 (now 15.0.1). When I deleted the app I suppose the charts I had were also deleted so will have to download those again as well.

Thanks for the info, that gives us a bit of clue for that problem. Do you recall the type of chart that you were using when the flashing happened? This is important as NOAA has officially discontinued the form of raster charts we are using and are in the process of shutting down the service which could potentially cause strange drawing to occur, possibly only in areas that have been shut down. We were about to release an update that removes the option to use raster charts, but now want to get to the bottom of this new issue fist.

Deleting the app does in fact delete ALL of the data associated with it including downloaded charts and data, any settings you’ve changed, and all of your navigation objects, buddies, and instrument panels. However, since your navigation objects, buddies, and instrument panels are cloud-synchronized, they will be restored when you start the app.

I was using Vector charts only. I did have Raster on the iPad but have not used them since they are too slow. Just tried opening my Collection and it opened showing the North Atlantic with all my nav objects along the coast. As I tried to zoom in the screen flipped to Lake Sammamish and the screen froze. Had to reboot to start over.
Question: How do I make my area the default charts?

Ok, I think we’ve made some progress… I was able to get “something bad” to happen by selecting vector charts, zooming way out, and panning over to the East Coast. What I saw was a single white flash and then the chart was redrawn at the default location. This is similar to what both of you are saying, but I am only seeing a single white flash rather than continuous flashing. In addition, Coastal Explorer is remaining responsive (though obviously not always showing the part of the chart I want to see).

While this is not exactly the same symptom, it is similar enough that I suspect it is related and since I can now reproduce this problem we should be able to work on solving it. Hopefully solving this will also solve the problems you are seeing.

What’s happening here is that something is causing the graphics processing part of the new iPadOS to crash which is then restarting Coastal Explorer. This is very strange as normally a problem like this between an app and iPadOS would simply cause the app to be terminated (which would also be annoying, but not quite as mysterious).

We are now working on providing a solution to this as quickly as possible. In the mean time, I have only seen this happen with vector charts and only when using a lot of them (by panning across the country), so you might try switching to Bing Aerial Photos or some other format and then zooming in on the area you want to see before switching to vector charts. The act of switching to vector charts will also save the location of the center of the chart so that if another restart is triggered, that should be where you end up.

The flashing and looping, as described above, happened after I updated to iOS 15. It seemed there was nothing I could do to get this under control so I deleted the app and downloaded a fresh copy from the App Store. After that the Flashing and Looping went away. All that remained was the flip to Lake Sammamish when trying to move the chart to the East coast and zooming. After selecting my Collection it appears the App is behaving well with the exception of always centering on Lake Sammamish on startup which requires moving the chart east each time.

Did my suggestion for fixing your default location not work (the last paragraph of my last comment)?

Sorry, just tried the Bing Photo chart. Yes it worked. I switched to Bing and than activated the boat icon on the bottom bar which brought me to my current position. Than scrolled to the Chesapeake and opened a route. Switched to Vector charts and all seems fine now.

Closing the App and reopening it holds the last position as expected.

Still flashing and looping - I can’t move around the map without going right back to where the boat is.
Really need this as I’m leaving on a trip in the morning
It was working perfectly last time we used the App - must be Apple iOs update

It turns out this is a bug in iOS/iPadOS 15 that is affecting many other apps too. Apple has been informed of the problem and we hope that they will issue an update to fix it soon. In the meantime, we are continuing to look for some way to work around the problem.

1 Like